getting pppd/pppoe to work

tom.haller at att.net tom.haller at att.net
Thu Feb 12 20:41:38 PST 2004


Hi all,

I followed the recent discussion on getting kernel pppoe to work. I turned on pppoe and all the other necessary bits in the kernel and recompiled it, and compiled pppd 2.4.2 with the built-in pppoe support. I set up my options file and chap-secrets file. When I run pppd eth0, the following is logged:

pppd[87]: Plugin rp-pppoe.so loaded.
pppd[87]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
pppd[88]: pppd 2.4.2 started by root, uid 0
pppd[88]: send (sendPacket)

Then nothing. If I run ifconfig eth0 I get:

eth0      Link encap:Ethernet  HWaddr 00:0B:DB:02:AA:AA  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xec80 

which is what it looks like before running pppd.

My /etc/ppp/options looks like this:

lock
plugin rp-pppoe.so
default-asyncmap
defaultroute
user 12341234 
usepeerdns
noauth

and my /etc/ppp/chap-secrets looks like this:

# client server secret     IP addresses
12341234 *      mypassword 0.0.0.0

I don't get any error messages. On the DSL modem I see only steady lights, not blinking. The NIC is okay because I can connect it to another box peer-to-peer using WinXP. The DSL itself is okay because I run my other box off it with Win2K.

I must be missing something really obvious. Help!

Tom




More information about the blfs-support mailing list