Problems building wmx

Ken Moffat ken at kenmoffat.uklinux.net
Wed Feb 11 13:36:55 PST 2004


On Wed, 11 Feb 2004 eklirmr at wanadoo.fr wrote:

>
> Hi Ken,
>
> Thanks for your reply.  Unfortunately there isn't a more recent
> release of wmx as far as I can see.  I've tried posting to the wmx
> list as well but my mails got returned.  Maybe the program just isn't
> maintained any more (pity).
>
 Maybe try learning enough c++ to fix it ? <joke>  I don't know what it
was like, but different people like blackbox, xfce, and icewm for fairly
lightweight windowmanagers.  Anyway, it's working, so you've got time to
research what to use for your next windowmanager.

> >
> >  It probably needs something different to override which version of g++
> > (the c++ front end to gcc) is used.  Maybe check this part of the BLFS
> > book again.
>
> I did, but it still confuses me.  After installing in /opt/gcc-2.95.3,
> the book says
>
> "Move the C++ libraries to the standard lib directory to avoid having to add /
> opt/gcc-2.95.3/lib to /etc/ld.so.conf.
>
> for i in /opt/gcc-2.95.3/lib/*.so*; do mv -f $i /usr/lib;
> ln -sf /usr/lib/`basename $i` /opt/gcc-2.95.3/lib; done"
>
>
> But then, a few lines further on,
>
> "As with most libraries, there is no configuration to do, save that the library
> directory i.e. /opt/lib or /usr/local/lib should appear in /etc/ld.so.conf so
> that ldd can find the shared libraries. After checking that this is the case, /
> sbin/ldconfig should be run while logged in as root.
>

 I think that paragraph is pretty much "boilerplate" - some of the BLFS
editors seem to stick it in whenever libraries are involved,

> The instructions given above make compatibility symlinks that pre-compiled
> packages in BLFS require. You may create additional compatibility links based
> on your requirements.
>
> If you only need the GCC-2.95.3 libraries, you may delete /opt/gcc-2.95.3.
>
> Whenever you need to use GCC-2.95.3 instead of you system installed compiler,
> add /opt/gcc-2.95.3/bin to the front of your PATH or (preferably) set the CC
> environment variable before compiling the concerned package."
>

 That ought to work, i.e. gcc --version should tell you which one you'll
use.  It certainly looked like you were using 3.3.1 when you tried to
build wmx.

> If the libraries are no longer in /opt/lib/ (or
> /opt/gcc-2.95.3/lib/?), why add the path to /etc/ld.so.conf?
>

 Indeed

> The reason I installed LFS5 was to have a stable, reliable Linux
> system, but now I already have bits of two different compilers
> scattered around the system and I'm getting worried!
>

 Only two ?  That's not many :)

> I've found an LFS hint on installing the two compilers together and
> switching between them using a script, but it involves installing the
> files in yet another location and I'm already getting headaches trying
> to remember where everything is ...
>
> If gcc 3.3.1 has all these problems, why not just stick with 2.95.3?
> If it's good enough for the kernel ...
>

 The big gain of the gcc-3.3 series so far has been adherence to the
(newer) c++ standards.  I don't write c++, but most modern gui stuff
should work better.  By about 3.3.4 it might even produce smaller code.

 3.3.1/2 produce good kernels under most circumstances, but for 2.4
kernels where you get a problem the standard response is "does it work
with gcc-2.95.3" so the book is cautious.  I believe we'll drop 2.95.3
when the book goes to 2.6.  But, your distro, your choice.

Ken
-- 
Brighton tops UK Jedi league
http://www.theregister.co.uk/content/28/35186.html




More information about the blfs-support mailing list