error compiling ppp-2.4.2

Steve Bougerolle steveb at creek-and-cowley.com
Sun Feb 8 17:45:56 PST 2004


On Sun, 2004-02-08 at 16:38, tom.haller at att.net wrote:

> When I do the make for ppp, I get errors starting with the compile of 
> options.c, as you can see below. pcap.h is nowhere to be found on my system.

The short fix is to download libpcap from http://www.tcpdump.org/

> I built my whole LFS with no problem, and have added lynx and ppp 2.4.1 with 
> no problem. This is my first major stumbling block. Thanks for any help 
> anyone can give me.

I don't know offhand why you need pcap for rp-pppoe, but I vaguely
recall much the same as what you said.  ppp itself compiles without
anything strange but the Roaring Penguin stuff needs more.





More information about the blfs-support mailing list