imPS/2 mouse under X-4.3.0.1 and linux-2.6.0

Alexander E. Patrakov semzx at newmail.ru
Sun Feb 8 00:04:52 PST 2004


On Sunday 08 February 2004 04:00, Dark wrote:
> I tried waiting for the mouse as you suggested, but it didn't start even
> after several minutes, but stood still in the middle of the screen. Only
> removing and inserting psmouse module helped.
>
> I tried searching google and found a lot of writings about similar
> problems with atkbd.c.
> Maybe a kernel bug?

No, it's not a bug. Now kernel tries to autodetect which mouse protocol the 
application expects. This causes problems with applications trying to 
determine automatically which protocol the mouse speaks. Solution: 

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "ImPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
EndSection

Note that I explicitly specified the protocol instead of letting X to 
autodetect it.

-- 
Alexander E. Patrakov



More information about the blfs-support mailing list