Cups 'printtime' problems

Alexander E. Patrakov semzx at newmail.ru
Fri Feb 6 22:08:15 PST 2004


cedric wrote:

>Hi all, i try to get my printer working with cups and esp ghostscript.
>
>All the software compiles and runs, but when i  print the cups testpage i get 
>nothing but lines of random dots on my paper. 
>
>At the first try i compiled foomatic ghostscript, and cups. 
>
>At the second attempt i compiled cups, ghostscript with the omni drivers, and 
>then cups again (for some reason)
>
>This didn't change much, in the web-admin of cups i only could choose the 
>HP Deskjet 500 (Foomatic/hpijs) 
>for my printer. (Witch is indeed a deskjet 500)
>
>I guess some of the foomatic (and hpijs) stuff has polluted my print setup. 
>
>How do i correct this?
>
You just didn't install additonal drivers. Foomatic looks for what is
available at compile time, and the "Foomatic" list never changes. 
Install gimp-print, and you will see

HP DeskJet 500 - CUPS+Gimp-Print v4.2.6 (en)
HP DeskJet 500C - CUPS+Gimp-Print v4.2.6 (en)

Select the right one, and it will work. You don't need Foomatic at all.

The correct order of insallation is:

1) CUPS
2) gimp-print 4.2.5 or 4.2.6 (don't use other versions)
3) ESP ghostscript (pass --without-gimp-print to the configure script)

-- 

Alexander E. Patrakov







More information about the blfs-support mailing list