Problems with Mozilla 1.6 under gnome desktop

root greenjh at blueyonder.co.uk
Wed Feb 4 02:54:38 PST 2004


Hi,

The solution is in point 4 near the end, for those who don't
want to read about my blunders,

I built mozilla 1.6 wth Gnome under fairly recent CVS versions
of LFS and BLFS.  Unfortunately, Mozilla hangs under certain
circumstances.  Other Internet and X applications do not have
similar problems.

Mozilla can be made to hang by pressing Ctrl and + or Ctrl and -,
which are used to change the font size.  It hangs even if the
only open window is simply displaying a jpeg.  After the hang,
top shows no process using lots of cpu time, and it is easy to
kill mozilla from an xterm.  There is nothing relevant in
/var/log.

For some time, it seemed that mozilla worked perfectly under the
Tab Window Manager, but it was not so.  It just takes much longer
to fail in normal use under the Tab WM.

I tried rebuilding Mozilla 1.6 with --disable-xft, but it made
no difference.

I deleted Mozilla 1.6 and built Mozilla 1.5.  It had the same
problem.  Anyway, I am not sure I removed 1.6 cleanly.

I tried using strace to find out what goes wrong, but I could not
understand the output.  For one thing, starting mozilla creates
a process tree like this (lines from 'ps waxf' truncated
somewhat):

626 pts/2 S 0:00 \_ /bin/sh /usr/lib/mozilla-1.5/run-mozilla.sh /usr/li...
631 pts/2 S 0:05 |   \_ /usr/lib/mozilla-1.5/mozilla-bin
633 pts/2 S 0:00 |       \_ /usr/lib/mozilla-1.5/mozilla-bin
634 pts/2 S 0:00 |           \_ /usr/lib/mozilla-1.5/mozilla-bin
635 pts/2 S 0:00 |           \_ /usr/lib/mozilla-1.5/mozilla-bin
636 pts/2 S 0:00 |           \_ /usr/lib/mozilla-1.5/mozilla-bin
637 pts/2 S 0:00 |           \_ /usr/lib/mozilla-1.5/mozilla-bin

Tracing all these processes requires 'strace -f mozilla', but
the resulting output is hard to interpret.  Even when the
application is doing nothing, strace shows lots of 'nanosleep'
activity, and I could not locate where the hanging
occurs in the record.

I also tried gdb.  I downloaded and built gdb 6.0, since the
instructions for gdb in Chapter 12 involve Ada and other
stuff.  Unfortunately, I have stripped my binaries, otherwise
the installation would not fit on my laptop.  Even Mozilla is
built with a --strip option.  Then I had the difficulty of
identifying the process to watch.

I gave up trying to pinpoint the problem and went back to
random changes and hope.  A list follows.

1.  When mozilla exits, I always get a message:

    /dev/dsp: No such device

   Is this a digital signal processor?  I do not use sound
   on my laptop, so I used Mozilla/Edit/Preferences to remove all
   sound effects.  No improvement.

2. Try killing sendmail before starting mozilla.  No improvement.

3. Change Mozilla's theme from Classic to Modern.  No improvement.

4. Try a binary (mozilla-i686-pc-linux-gnu-1.6-installer.tar.gz).
   The problem went away.  The /dev/dsp message also went
   away.

This gives no clear understanding.   Eventually, I will rebuild
LFS and BLFS from (ahem) scratch with Linux 2.6, the latest
package versions, fewer packages and fewer mistakes.  And I will
build and test mozilla earlier so I can detect problems before
building a ton of Gnome stuff.  In any case, being able to
run Mozilla means the BLFS system can maintain itself without
booting into the host.

John Green





More information about the blfs-support mailing list