Where did UTF-8 go? (answer: it was never there)

Alexander E. Patrakov patrakov at ums.usu.ru
Thu Dec 30 08:24:48 PST 2004


Peter B. Steiger wrote:

> In an effort to increase the speed of the DRI drivers for my Radeon, I
> upgraded to the newest bleeding-edge (but stable) versions of the kernel
> (2.6.10), X (xorg 6.8.2), and Gnome (not because that was necessary for
> DRI, but because I was in an upgrading mood anyway).
> 
> All of a sudden, Unicode won't display properly.  It's not related to any
> one application; Evolution and Firefox have both stopped showing Unicode
> characters properly - now I just get a weird box with four hex codes in
> it.  I have no idea which of my changes took away UTF capability.  The
> last time I built LFS, I didn't need to know or do anything special to get
> UTF; I just followed the recipe and everything worked.  I thought I was
> following the directions this time, too, but obviously I broke something
> along the way.

Are you talking about the UTF-8 hint? Don't use it, it's outdated and even
wrong for LFS 6.x.

For the best (but still not perfect) UTF-8 support, you must install RedHat
Enterprise Linux. UTF-8 will never be in the LFS or BLFS book because it
conflicts with our "minimal patches" policy and the official maintainers of
many packages (e.g. grep and gawk) don't fix known UTF-8-related bugs (even
with known fixes) thus forcing distros to fork the software.

An obvious checklist in your case is the installation of fonts and
fontconfig.

Try installing the freetype2-demos package and running the following
command:

ftview -r 100 ppem /path/to/your/favourite/font.ttf

Then try pressing F9 and F10 to display different ranges of characters. Do
they look right?

Next, try running xfontsel in order to test font accessibility for non-Xft
apps. Are the fonts there?

Then try running gucharmap in order to see which fonts are available to
Xft-based apps (this will also test fontconfig).

> I reverted back to my 2.6.7 kernel, restored my backup of freetype,
> restored my backups of XFree86 4.40... nothing works.
> 
> Normally when I compile I use the --disable-nls option because as an
> American of course I have no need for anything but God's own language,
> English :-) but I made sure to include UTF support in the kernel options,
> and I left off the --disable-nls when I built Freetype and X.

The use of --disable-nls switch is not supported at all by LFS.

> What else am I missing?  What compile/configure flags, additional files or
> packages, do I need to get UTF working again?  I'd like to at least be
> able to read the Cyrillic that shows up on web sites even if I have to use
> a dictionary to find out what it means.

You are in fact talking not about UTF-8 but about the ability to display
international characters. The kernel is irrelevant to that.

-- 
Alexander E. Patrakov



More information about the blfs-support mailing list