Undefined References in LFS6, BLFS 2004-12-24

Declan Moriarty declan.moriarty at gmail.com
Thu Dec 30 02:03:47 PST 2004


On Wed, 29 Dec 2004 20:15:08 +0000, Carlos Eduardo de Brito Novaes
<carlos_tocha at ig.com.br> wrote:
>     Hello, and happy new year for all.
> 
>     Well, this time i'm building a LFS6 system, but when i was compiling
> BLFS6, i got some strange errors in some packages (3 by now).
>     These are the errors and the packages:
>     1) Undefined reference to fnmatch (char *, char*, int) on wvstreams
> and kdesdk. --> When i got this error, i search for a library ith this
> function, it was libc. But the test suite to glibc was OK. I can even
> compile a "c" test program with fnmatch function and it worked, so i
> don't know why thes two packages cannot compile.
>     2) Undefined reference to glob(...) on kdeadmin. Again this is a
> glibc function, this time i had removed lilo-config from kdeadmin and it
> compiles ok (i know it was ugly).
> 
>     The binutils test suite was OK too, so i guess, does anyone had an
> idea or advice?
> 
I would imagine the gcc version would be the first thing to look at.
What version are you using? The application of standards and syntax is
increasingly stringent with recent versions of gcc. This breaks
basically everything until they tighten up the code.

Have you tried an earlier version of gcc?
-- 
     All the Best

     Declan.



More information about the blfs-support mailing list