unexdpected mouse problems in console (mx1000 related?)

Wouter Mense woutermense at gmail.com
Tue Dec 28 06:15:26 PST 2004


Declan wrote:
> Yeah, with udev is on it's way in. You can have fun there
> 
> Console, I presume, as LFS does not supply X. Some usb event is
> mucking up, and getting onscreen. It is coming in and generating
> interrupts, which nothing is picking up. Can  you compile gpm, run it,
> and see if things behave?  I'm back on LFS-3.3, and avoiding the
> bleeding edge, hotplug, and udev until they get sorted and someone
> else has the grey hairs.
> I would check what resources are assigned.
> cat  /proc/interrupts
> cat  /proc/ioports
> lsmod
> Is your mouse showing?
> 
> /Wildly guessing
> Something may be picking up that mouse (e.g. a keyboard driver)

I compiled GPM and it looks like its 'behaving'. Can move the mouse
and see the pointer move also. But still those letters. Also if i
happen to run w3m for reading the BLFS book, and i want to press a
mouse button at the same time, w3m gets killed.

/proc/interrupts shows: (was nicely aligned in monospace font)
           CPU0       
  0:     140549    IO-APIC-edge  timer
  1:        415    IO-APIC-edge  i8042
  6:         71    IO-APIC-edge  floppy
  9:          0   IO-APIC-level  acpi
 14:        663    IO-APIC-edge  ide0
 15:         24    IO-APIC-edge  ide1
 19:         38   IO-APIC-level  uhci_hcd
 20:          3   IO-APIC-level  ohci1394, eth0
 23:         12   IO-APIC-level  ehci_hcd, uhci_hcd, EMU10K1
NMI:          0 
LOC:     140490 
ERR:          0
MIS:          0

/proc/ioports:
0000-001f : dma1
0020-0021 : pic1
0040-005f : timer
0060-006f : keyboard
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial
0376-0376 : ide1
0378-037a : parport0
03c0-03df : vga+
03f2-03f5 : floppy
03f6-03f6 : ide0
03f7-03f7 : floppy DIR
03f8-03ff : serial
0cf8-0cff : PCI conf1
b000-b01f : 0000:00:1f.4
  b000-b01f : uhci_hcd
b400-b41f : 0000:00:1f.2
  b400-b41f : uhci_hcd
b800-b80f : 0000:00:1f.1
  b800-b807 : ide0
  b808-b80f : ide1
d000-d0ff : 0000:02:0c.0
  d000-d0ff : 8139too
d400-d407 : 0000:02:0b.1
d800-d81f : 0000:02:0b.0
  d800-d81f : EMU10K1
e400-e47f : 0000:00:1f.0
e800-e80f : 0000:00:1f.3
ec00-ec3f : 0000:00:1f.0

I have no running/loaded modules, so lsmod shows nothing.

So i guess my mouse doesn't show. Or it's those uhci and ehci drivers
for usb that represent my mouse. EMU10K1 is my soundcard chip btw.


Wouter



More information about the blfs-support mailing list