w3m error in configure: cannot compute sizeof (long long), 77 SOLVED

cedric at softhome.net cedric at softhome.net
Sun Dec 19 02:58:19 PST 2004


On Saturday 18 December 2004 14:35, John Shelton wrote:
> cedric at softhome.net wrote:
> > Hi all,
> >
> > I'm compiling w3m-0.4.2, on my shiny-new lfs-6.0 system, and i get the
> > following error. Has anybody seen this one before?
>
> <snip>
>
> > checking size of long long... configure: error: cannot compute sizeof
> > (long
>
> i haven't but others have.
> google for w3m "cannot compute sizeof" and see what you find.
> from what i read it might be a problem with Boehm GC (??) or something.
> the error was also reported on a freebsd list so i doubt it's LFS specific.
issue the following command solved my problem, but don't understand fully what 
this does:
export LDFLAGS='-Xlinker -R/usr/local/lib'

and does it hurt to leave this variable set, or should i unset it right away?
I'm a bit ashamed for not googling before posting

Thanks, cedric
-- 
The only stupid question is the one you don't ask



More information about the blfs-support mailing list