Freetype, Pango, or something error.

Alex Kloss Klossa at students.uni-marburg.de
Tue Dec 7 09:48:47 PST 2004


Hi, Declan

Have you tried setting your PKG_CONFIG_PATH to /usr/X11R6/lib/pkgconfig? This helped on my system.

Greetings, LX

On Tue, 7 Dec 2004 17:40:07 +0000
Declan Moriarty <declan.moriarty at gmail.com> wrote:

> Not a good day here folks. I reckon I'm one patch short somewhere.
> 
> I tried to add a little to my LFS-5.0/5.1/6.0 which is gradually
> bloating out on the HD here.
> Abiword wanted gtk; gtk wanted Pango, & mebbe Glib; Pango wasn't happy
> with freetype.
> 
> The pango build crapped out looking for ftmodule.h to be included. It
> WAS included, but there was an extra config/ in the path
> /usr/include/freetype2/freetype/config/ftmodule.h :-O.
> So I hacked into the complaining  C file, changed that path and then
> it slowly crapped over syntax, as attached. It's over my head this
> time.
> 
> I think I have fallen into some hole - I'm a patch short, an out of
> date book, wrong package versions, or something. I'm using:
> Pango-1.2.3; gtk+-2.4.12; freetype-2.1.9; 2.4x kernel; gcc-3.3.1;
> glibc-2.3.2; Xorg-6.8.1; freetype-2.1.9; glib-2.0.1. They just
> happened to be what I had lying here.
> 
> Any ideas??
> -- 
>      All the Best
> 
>      Declan.
> -- 
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page



More information about the blfs-support mailing list