problems with gnome 2.8, nautilus, eog

Olaf Gruettner olaf.gruettner at web.de
Sat Dec 4 15:12:06 PST 2004


> > I installed gnome 2.8. Now I have the problem, that jpeg files are not
> > shown by nautilus. Clicking on them says "no appropriate application
> > installed" or something like that.
> > 
> > I searched the mail archives for nautilus, eog and gnome.
> > I have eog installed (2.8)
> > I have XDG_DATA_DIRS set to /usr/share + exported the Variable
> > I have gnome installed to /usr
> > Dragging and dropping jpeg files onto eog is not displaying anything.
> > I have reinstalled nautilus, eog, shared mime data with no success.
> > 
> > What could be the problem ? Hints ? FAQ ?
> 
> I'm not sure where to point you on this one. It all works for me on
> my GNOME-2.8 installation. Nautilus shows the .jpg/.jpeg file with
> an icon of the picture displayed correctly. Double-clicking opens
> up eog with the picture displayed, and dragging the file into eog
> from Nautilus opens up the picture correctly.

part of the problem is solved. I did an 
update-mime-database /usr/share/mime
and now my nautilus is thumbnailing png files. eog is displaying png
files like it should.

unfortunately my jpeg are still not showing up.
a new installation of the libjpeg was no success. no errors showed while
installing but it didn´t make eog or nautilus show the pictures.

Any new ideas?

Olaf



More information about the blfs-support mailing list