error with xfree or xorg

Le Floch Jérémy jeremy.lefloch at wanadoo.fr
Sat Dec 4 01:00:17 PST 2004


Hello everyone.

I have compiled lfs and i would like install X11 on it.
I've tried xfree and xorg but always the same error !

rm -f xf86drm.o

gcc -m32 -c -O2 -fno-strength-reduce -fno-strict-aliasing  -ansi -pedantic -pipe  -I../../../../exports/include/X11 -I../../../../include/extensions    -I../../../../programs/Xserver/hw/xfree86/os-support/linux/drm          -I../../../../programs/Xserver/hw/xfree86/os-support/linux/drm/kernel           -I../../../../programs/Xserver/hw/xfree86/os-support/linux/drm/kernel           -I../../../../programs/Xserver/hw/xfree86/os-support  -I../../../.. -I../../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                        -D_POSIX_SOURCE -D_XOPEN_SOURCE                                 -D_BSD_SOURCE -D_SVID_SOURCE                             -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO   -DMALLOC_0_RETURNS_NULL   xf86drm.c

In file included from xf86drm.c:72:

drm.h:41: erreur: erreur d'analyse syntaxique avant un élément lexical « / »

make[6]: *** [xf86drm.o] Erreur 1

make[6]: Leaving directory `/usr/src/packages/xc/lib/GL/dri/drm'

make[5]: *** [all] Erreur 2

make[5]: Leaving directory `/usr/src/packages/xc/lib/GL/dri'

make[4]: *** [all] Erreur 2

make[4]: Leaving directory `/usr/src/packages/xc/lib/GL'

make[3]: *** [all] Erreur 2

make[3]: Leaving directory `/usr/src/packages/xc/lib'



Into chroot or under lfs, the same error ! Could anyone help me ?
Sorry for my bad english, i'm french ^^

Jérémy.




More information about the blfs-support mailing list