librsvg

Randy McMurchy randy at linuxfromscratch.org
Wed Dec 1 21:07:47 PST 2004


Dennis J Perkins wrote:
> I'm trying to build librvg according to the development version and it 
> keeps dying at this point.  If I include --disable-gk-doc, it will 
> build.  But I don't see what is causing the problem.
> 
> mkdir ./html
> cd ./html && gtkdoc-mkhtml rsvg ../rsvg-docs.sgml
> file:///usr/share/xml/docbook/xsl-stylesheets-1.62.4/VERSION:1: parser 
> error : Start tag expected, '<' not found
> 1.78
> ^
> compilation error: file 
> file:///usr/share/xml/docbook/xsl-stylesheets-1.62.4/html/docbook.xsl 
> line 23 element include
> xsl:include : unable to load 
> file:///usr/share/xml/docbook/xsl-stylesheets-1.62.4/VERSION
> make[2]: *** [html-build.stamp] Error 5
> make[2]: Leaving directory `/usr/src/gnome/librsvg-2.8.1/doc'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/gnome/librsvg-2.8.1'
> make: *** [all] Error 2

It looks as though your XSL Stylesheets installation is fouled up.
Try re-installing that package and see what happens. If not the
XSL Stylesheets package, it is something else with the DocBook
installation.

-- 
Randy



More information about the blfs-support mailing list