XFree86 DRI Compile Problems

esaul esaul at reggaetrain.com
Thu Jul 31 08:42:45 PDT 2003


On Thu, 31 Jul 2003 21:10:32 +0200, Christoph Berg wrote:

> Hello,
> 
> I have successfully completed the building and installing of XFree86
> 4.3, but now I have the problem with compiling the DRI modules. When I
> type
> 
> make -f Makefile.linux
> 
> it gives me this error.

> === WARNING Use 2.4.x kernels ONLY !

> *** Kernel modules must be configured.  Build aborted.
> 
> I have kernel support for DRI enabled and built the module for my
> graphic card.

Could it be because you are using a 2.5.*-2.6.? kernel? All the
module stuff has been re-made in those kernels. Unless you tweak it a bit,
X can only build 2.4 modules.



More information about the blfs-support mailing list