Xfree86 with no AGP

Amit Mehra amitm at tgs-solutions.com
Wed Jul 30 03:48:00 PDT 2003


Hello,
          I am facing problem installing XFree86-4.3.0  on my intel815
board. I think the only problem is with AGP. My board does not have any
AGP, neither on board or on PCI but it is a chipset with integrated
Graphics. On giving the XFree86 -xf86config ~/XF86Config.new command the
system does not show grey screen as mentioned in the documents instead
in reports an error stating
|
|
|
(--) I810(0): IO registers at addr 0xFFA80000
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(EE) I810(0): AGP GART support is not available.  Make sure your kernel
has
 agpgart support or that the agpgart kernel module is loaded.
(II) UnloadModule: "i810"
(II) UnloadModule: "ddc"
(II) Unloading /usr/X11R6/lib/modules/libddc.a
(II) UnloadModule: "int10"
(II) Unloading /usr/X11R6/lib/modules/linux/libint10.a
(II) UnloadModule: "vbe"
(II) Unloading /usr/X11R6/lib/modules/libvbe.a
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
.
.
..

To resolve this I tried the following things but have achieved no
success:

- Disabled the support of AGP from Kernel, recompiled Kernel and then
Build Xfree86.
- Made changes to XF86Config.new by keeping only default depth and
removing all Subsection Display except with depth 16.

I have attached the XFree86.log for your reference, would appreciate
anybody's help.

Thanks,
Amit
-------------- next part --------------
A non-text attachment was scrubbed...
Name: amitm.vcf
Type: text/x-vcard
Size: 346 bytes
Desc: Card for Amit Mehra
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20030730/ddeef2ea/attachment.vcf>


More information about the blfs-support mailing list