tcl8.4.4 not compatible with expect-5.38?

Matthew Burgess ca9mbu at hermes.sunderland.ac.uk
Tue Jul 29 16:02:11 PDT 2003


On Tue, 29 Jul 2003 13:19:15 -0400
esaul <esaul at reggaetrain.com> wrote:

> Nope, with 8.4.2, making check in expect, I get the same error:
> 
> " . . . TCL_LIBRARY=/home/lfs/builds/tcl8.4.2/library ; \
> 	export TCL_LIBRARY ; fi ; \
> LD_LIBRARY_PATH=.:/stage1/lib:/stage1/lib:$LD_LIBRARY_PATH ./expect -f
> .tmp
> ./expect: relocation error: /stage1/lib/libc.so.6: symbol
> __libc_stack_end, version GLIBC_PRIVATE not defined in file
> ld-linux.so.2 with link time reference . . ."
> 
> Could it have something to do with the base system (Mandrake 9.1)? As
> it is now, expect won't even install citing the same error. Good thing
> I didn't go too far with the lfs install, I can restart again (third
> time!)

It didn't look like a tcl/expect incompatibility anyway.  Looks more
like a problem with glibc.  What versions of glibc and gcc are you
using?  From a quick look in the mailing list archives (you did look
there first, right?) it looks as though you might have messed up in
editing your gcc specs file (I refer to
http://archives.linuxfromscratch.org/mail-archives/lfs-support/2003-April/016519.html
and onwards in that thread).

Hope this is of some use,

Matt.




More information about the blfs-support mailing list