CVS 20030603 and BLFS shadow-4.0.3

S. Anthony Sequeira tony at neutronstar.fsnet.co.uk
Mon Jul 28 01:31:00 PDT 2003


"Jeremy Utley" wrote:
[...]
> Dagmar, and everyone else -
>
> I brought this to the attention of LFS-dev a few months back, when we
> first
> discovered that libtool 1.5 was screwing with libfam.  The thread I
> started
> it is here in the archives:
>
>
http://archives.linuxfromscratch.org/mail-archives/lfs-dev/2003/05/1182.
> html
>
>
> The final determination was that this is a side effect of the patches
> made to
> fam and other packages...this is a quote from Greg a few messages into
> it:
>
> <quote Greg Schaefer>
> The breakage is caused by the rerunning of the autotools.  What is
> happening
> is this:
>
>  - The BLFS patch touches various autotools files that force them to
> be rebuilt
>
>  - part of this rerunning involves running aclocal
>
>  - aclocal recreates aclocal.m4 (it's programmed to look at
> /usr/share/aclocal which, lo & behold, contains libtool.m4 from the
> libtool-1.5 package!)
>
>  - we now have a mismatch coz the ltmain.sh in the fam tarball is
> version
> 1.4 but the aclocal.m4 was created from the 1.5 m4 file.  This is
> broken,
> broken, broken!
>
> The fix is to run:
>
> libtoolize --force
>
> immediately after applying the fam patch
>
> </quote>
>
> I'm in the process of building a LFS-CVS build right now, so I will
> test out this libtoolize --force command to see if it does the right
> thing.
>
> Hope this helps!
>
> -J-
libtoolize --force

DOES work, do it straight after the patch and before the autoconf.

Thanks guys.




---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.502 / Virus Database: 300 - Release Date: 18/07/2003





More information about the blfs-support mailing list