XFree86 4.3.99.9 (cvs) & xfs

Dagmar d'Surreal dagmar.wants at nospam.com
Sun Jul 27 18:10:21 PDT 2003


On Sun, 2003-07-27 at 19:12, Yann E. MORIN wrote:
> On Monday 28 July 2003 01:31, you (Dagmar d'Surreal) wrote :
>  > xfs doesn't start itself, you know.  If you do this configuration
>  > change, you will have to start xfs yourself before you start X.
> 
> Yes, I know! That's why I made a script in /etc/rc.d/init.d I called
> xfs, and that is started at boot time, which calls xfs with
> -daemon -config /etc/X11/fs/config   options. And the script is
> symlinked in rc5.d as S85xfs. Which should suffice.
> 
> Alternatively, I ran xfs from cmd line, restarted X (with Ctrl-Alt-BS)
> and looked back to the console where I started xfs : nothing, and
> the log said XFree could not initialize that particuliar FontPath.
>
> Here I'm stuck with it... I tried every combinations of tcp and unix
> protocols, with 127.0.0.1 or localhost, or even the real hostname,
> changing the port to an (un)privildged one (below 1024), but that
> didn't help either... :-(

On general principle, 127.0.0.1 is the best bet for safety's sake, since
you can (with some luck) prevent other schmucks on the internet from
attaching to it there, and it involves the fewest moving pieces.  The
port number you can leave at the default.

> What I don't get is that my MDK with XFree 4.?.? (!4.3) works with xfs
> and I 'copied' the config files from it... :-/ Weird...

No idea.  Checking log files would help tho.  What you _need_ to do is
make certain it's running after you think you've started it.  Do a ps
-ef | grep xfs to check for it in the process list.  Do a netstat -tunap
| grep xfs (as root) to spot that it's actually bound to the port it's
supposed to bind to.  Then lastly, check that it's properly accepting
connections and not just stuck there by telnetting to that port on
localhost.  The connection should _completely_ open.  The odds are at
least one of these tests will fail.

> In the meantime, I recompiled X, and now xfs spits out something
> regarding inet6, stating it can't somewhat open a socket, which I
> suppose is related to IPv6, which my kernel does _not_ support (on
> purpose!). But xfs says no such thing for inet4 (or whatever IPv4 is).
> Weird again... I assume it can initialize itself for IPv4.

Okay, that should be a big warning sign right there.  Assuming is
dangerous.  It's likely it's hitting the IPv6 error and bailing out
entirely, but see above.

> Well, I guess I have nothing to meddle in /etc/xinetd.conf, as xfs
> is no service, but please can you back that up?

That would be correct.  Xfs runs standalone, so you don't need to change
the superserver's configuration for it.

> Thanks for your attention, Dagmar!

You're welcome.

You might wish to take Bruce's suggestion to heart and just quit trying
to use xfs as standalone.  He's right, it's pretty much useless now
unless you've got literally many thousands of fonts and have them
installed on central machine on your local network.
-- 
The email address above is just as phony as it looks, and for obvious reasons.
Instant messaging contact nfo: AIM: evilDagmar  Jabber: evilDagmar at jabber.org




More information about the blfs-support mailing list