XFree86 4.3.99.9 (cvs) & xfs

Yann E. MORIN yann.morin.1998 at anciens.enib.fr
Sun Jul 27 17:12:12 PDT 2003


On Monday 28 July 2003 01:31, you (Dagmar d'Surreal) wrote :
 > xfs doesn't start itself, you know.  If you do this configuration
 > change, you will have to start xfs yourself before you start X.

Yes, I know! That's why I made a script in /etc/rc.d/init.d I called
xfs, and that is started at boot time, which calls xfs with
-daemon -config /etc/X11/fs/config   options. And the script is
symlinked in rc5.d as S85xfs. Which should suffice.

Alternatively, I ran xfs from cmd line, restarted X (with Ctrl-Alt-BS)
and looked back to the console where I started xfs : nothing, and
the log said XFree could not initialize that particuliar FontPath.

Here I'm stuck with it... I tried every combinations of tcp and unix
protocols, with 127.0.0.1 or localhost, or even the real hostname,
changing the port to an (un)privildged one (below 1024), but that
didn't help either... :-(

What I don't get is that my MDK with XFree 4.?.? (!4.3) works with xfs
and I 'copied' the config files from it... :-/ Weird...

In the meantime, I recompiled X, and now xfs spits out something
regarding inet6, stating it can't somewhat open a socket, which I
suppose is related to IPv6, which my kernel does _not_ support (on
purpose!). But xfs says no such thing for inet4 (or whatever IPv4 is).
Weird again... I assume it can initialize itself for IPv4.

Well, I guess I have nothing to meddle in /etc/xinetd.conf, as xfs
is no service, but please can you back that up?

Thanks for your attention, Dagmar!

Regards,
Yann.

-- 
.-----------------.--------------------.-------------------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON CAMPAIGN --- |
| +0/33 662376056 | Software  Designer | \ /  AGAINST HTML E-MAIL  \e/ |
| --==< °_° >==-- °---.----------------:  X    Erics' conspiracy :  v  |
| web: ymorin.free.fr | SETI at home 1813 | / \   There is no conspiracy. |
°---------------------°----------------°-------------------------------°
 \__ np: 05 - A Mireille dit Petit Verglas ___________________________/



More information about the blfs-support mailing list