XFree86 4.3.99.9 (cvs) & xfs

Yann E. MORIN yann.morin.1998 at anciens.enib.fr
Sun Jul 27 08:42:33 PDT 2003


Hi all!

I'm trying to get my X to use xfs instead of local' fonts. For this I set up
xfs with (hand copied):

client-limit = 10
clone-self = on
port = 7100
use-syslog = on
error-file = /var/log/xfs.log
catalogue = [rather long list here!]
default-point-size = 120
default-resolutions = 75,75,100,100
cache-hi-mark = 2048
cache-low-mark = 1433
cache-balance = 70

Those cache values are those by default. I just changed client-limit, added
the port, and modified catalogue to match my fonts dirs.

This is what I have in the Files section of XF86Config-4:
...
FontPath "tcp/127.0.0.1:7100"
...

What I get in /etc/log/XFree86.0.log is :
...
Could not init font path element tcp/127.0.0.1:7100, removing from list!
...

Of course xfs does not spits out any error, whether it is run in daemon
mode or from the command line, whether it uses or not syslog.
xfs.log does not even have a single line in it.

I tried the "unix/127.0.0.1:7100" font path, and I even tried the line
from my MDK: "unix/:-1" and nothing did work...

I'm currently using cvs from 20030725, but it happened as well with
4.3.(whatever it was about two months ago) so I decided to upgrade to
check, but to no avail.

Any hint?

And, by the way, I also lost my "<>" key in X on a french keyboard.
As well as the home, end (and maybe others) that do no longer work...
Any suggestion?

TIA.

Regards,
Yann.

-- 
.-----------------.--------------------.-------------------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON CAMPAIGN --- |
| +0/33 662376056 | Software  Designer | \ /  AGAINST HTML E-MAIL  \e/ |
| --==< °_° >==-- °---.----------------:  X    Erics' conspiracy :  v  |
| web: ymorin.free.fr | SETI at home 1812 | / \   There is no conspiracy. |
°---------------------°----------------°-------------------------------°
 \__ np: The Police - Hungry For You (J'aurais Toujours Faim de Toi __/



More information about the blfs-support mailing list