GConf-2.3.2 make error / markup-tree.c

Dagmar d'Surreal dagmar.wants at nospam.com
Fri Jul 25 13:10:11 PDT 2003


On Fri, 2003-07-25 at 09:59, julius junghans wrote:
> this is the error i get, configure runs just with prefix
> what can that be?
> 
> gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I.. -I../gconf -DORBIT2=1 -pthread -I/usr/src/evolution-1.4.3/glib-2.2.0/include/glib-2.0 -I/usr/src/evolution-1.4.3/glib-2.2.0/lib/glib-2.0/include -I/usr/src/evolution-1.4.3/orbit2-2.7.3/include/orbit-2.0 -I/usr/src/evolution-1.4.3/linc-1.0.3/include/linc-1.0 -I/usr/src/evolution-1.4.3/libxml-2.5.8/include/libxml2 -DGCONF_ENABLE_INTERNALS=1 -DG_LOG_DOMAIN=\"GConf-Backends\" -g -O2 -Wall -c markup-tree.c  -fPIC -DPIC -o .libs/markup-tree.lo
> markup-tree.c:2955: parse error before "FILE"

That you're a) not properly wrapping at ~78 colums, and b) a whole
fsckton of other things...

1. You're compiling ORBit-2.7.3, which is from Gnome Desktop 2.3.  Use
ORBit2-2.6.3, like it sez in the book, which is part of Gnome Desktop
2.2.  In practice, Evolution 1.4.3 (which I'm using right now, in fact)
should be compiled against Gnome Desktop 2.2 releases, with the
exception of the 4 or so packages you'll find it keeping company with
over on Ximian's file server.

2. You're compiling against things which you apparently _haven't
actually installed yet_, which is another way to push the odds towards
failure.  If you did install these already, you've done something really
broken because those include paths should be completely and utterly
unnecessary.  (Do not, do not, do not attempt to build that way.)

3. The version of glib you're trying to use is almost opposite of
ORBit2...  ORBit2 being to high a version, and glib-2.2.0 being too low
a version.  Use glib-2.2.2 (and gtk+).
-- 
The email address above is just as phony as it looks, and for obvious reasons.
Instant messaging contact nfo: AIM: evilDagmar  Jabber: evilDagmar at jabber.org

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list