CVS 20030603 and BLFS shadow-4.0.3

S. Anthony Sequeira tony at neutronstar.fsnet.co.uk
Fri Jul 25 06:23:58 PDT 2003


There appears to be a problem with the News server and OE, but:

libtoolize --force

It DOES work, do it straight after the patch and before the autoconf.

Thanks guys.

"Jeremy Utley" wrote:
>> -----Original Message-----
>> From: blfs-support-bounce at linuxfromscratch.org
>> [mailto:blfs-support-bounce at linuxfromscratch.org]On Behalf Of
>> S. Anthony
>> Sequeira
>> Sent: Thursday, July 24, 2003 4:52 PM
>> To: blfs-support at linuxfromscratch.org
>> Subject: Re: CVS 20030603 and BLFS shadow-4.0.3
>>
>>
>> Dagmar d'Surreal wrote:
>
>
>>>
>>> 1. Get a very large gun.
>>>
>>> 2. Press it gently against libtool-1.5.
>>
>> s/libtool-1.5/forehead/ <G>
>>
>>> 3. Pull the trigger.
>>>
>>> 4. Compile and install libtool-1.4.3.
>>>
>>> Libtool 1.5 is broken like hell with respect to numerous
>> packages and
>>> I
>>> can only hope it's not actually in the CVS version of the
>> book.  It's
>>> a
>>> shot in the dark on my part to guess that you're running it, but
>>> considering that nothing else changes "so" to "0" when it messes up,
>>> it's a pretty big target to shoot at.
>>
>
> Dagmar, and everyone else -
>
> I brought this to the attention of LFS-dev a few months back, when we
> first
> discovered that libtool 1.5 was screwing with libfam.  The thread I
> started
> it is here in the archives:
>
>
http://archives.linuxfromscratch.org/mail-archives/lfs-dev/2003/05/1182.
> html
>
>
> The final determination was that this is a side effect of the patches
> made to
> fam and other packages...this is a quote from Greg a few messages into
> it:
>
> <quote Greg Schaefer>
> The breakage is caused by the rerunning of the autotools.  What is
> happening
> is this:
>
>  - The BLFS patch touches various autotools files that force them to
> be rebuilt
>
>  - part of this rerunning involves running aclocal
>
>  - aclocal recreates aclocal.m4 (it's programmed to look at
> /usr/share/aclocal which, lo & behold, contains libtool.m4 from the
> libtool-1.5 package!)
>
>  - we now have a mismatch coz the ltmain.sh in the fam tarball is
> version
> 1.4 but the aclocal.m4 was created from the 1.5 m4 file.  This is
> broken,
> broken, broken!
>
> The fix is to run:
>
> libtoolize --force
>
> immediately after applying the fam patch
>
> </quote>
>
> I'm in the process of building a LFS-CVS build right now, so I will
> test out this libtoolize --force command to see if it does the right
> thing.
>
> Hope this helps!
>
> -J-




---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.502 / Virus Database: 300 - Release Date: 18/07/2003





-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list