CVS 20030603 and BLFS shadow-4.0.3

Dagmar d'Surreal dagmar.wants at nospam.com
Thu Jul 24 13:23:16 PDT 2003


On Thu, 2003-07-24 at 14:08, S. Anthony Sequeira wrote:
> Hi all,
> 
> I must be doing something incredible stupid here, but for the life of me
> I cannot figure it out.
> 
> I rebuilt my system based on LFS CVS 20030603, with a few updated
> packages.  All went well
> until I hit BLFS shadow 4.0.3 rebuild when I had the following:
> 
> make[2]: Nothing to be done for `install-data-am'.
> make[2]: Leaving directory `/build/shadow-4.0.3'
> make[1]: Leaving directory `/build/shadow-4.0.3'
> mv: cannot stat `/lib/libmisc.so': No such file or directory
> mv: cannot stat `/lib/libshadow.so': No such file or directory
> 
> it seems to have created /lib/libmisc.0.0.0 and /lib/libshadow.0.0.0
> instead of .so libraries.  OK, I thought,
> scrapped the install and rebuilt with the specified automake and gettext
> versions.  Another week gone.
> 
> BUT I still get the same problem.  Anyone else.  I have searched and
> googled and RTFFAQ and etc to no avail.
> 
> Help, I have lost a week, and I'm back to where I have started.
> 
> # bzcat /packages/shadow-4.0.3.patch.bz2 | patch -Np1 &&
> autoconf &&
> LDFLAGS="-lpam -lpam_misc"
> ./configure --prefix=/usr --enable-shared --with-libpam &&
> make && installwatch -o /var/install/${PWD##*/} make install && rm
> /bin/vipw &&
> rm /bin/sg && mv /lib/{libmisc.*a,libshadow.*a} /usr/lib &&
> mv /lib/{libmisc.so,libshadow.so} /usr/lib &&
> ln -sf ../../lib/libshadow.so.0 /usr/lib/libshadow.so &&
> ln -sf ../../lib/libmisc.so.0 /usr/lib/libmisc.so && cp debian/securetty
> /etc/securetty
> 
> The middle of the logfile:
> 
> rm -fr .libs/libmisc.la .libs/libmisc.* .libs/libmisc.*
> gcc -shared  addgrps.lo age.lo basename.lo chkname.lo chkshell.lo
> chowndir.lo ch
> owntty.lo console.lo copydir.lo entry.lo env.lo failure.lo fields.lo
> getdate.lo
> hushed.lo isexpired.lo limits.lo list.lo log.lo login_access.lo
> login_desrpc.lo
> login_krb.lo loginprompt.lo mail.lo motd.lo myname.lo nscd.lo obscure.lo
> pam_pas
> s.lo pwd2spwd.lo pwdcheck.lo pwd_init.lo rlogin.lo salt.lo setugid.lo
> setup.lo s
> etupenv.lo shell.lo strtoday.lo sub.lo sulog.lo ttytype.lo tz.lo
> ulimit.lo utmp.
> lo valid.lo xmalloc.lo  -lpam -lpam_misc  -Wl,-soname -Wl,libmisc.0 -o
> .libs/lib
> misc.0.0.0
> (cd .libs && rm -f libmisc.0 && ln -s libmisc.0.0.0 libmisc.0)
> (cd .libs && rm -f libmisc && ln -s libmisc.0.0.0 libmisc)
> 
> HELP, please.

1. Get a very large gun.

2. Press it gently against libtool-1.5.

3. Pull the trigger.

4. Compile and install libtool-1.4.3.

Libtool 1.5 is broken like hell with respect to numerous packages and I
can only hope it's not actually in the CVS version of the book.  It's a
shot in the dark on my part to guess that you're running it, but
considering that nothing else changes "so" to "0" when it messes up,
it's a pretty big target to shoot at.
-- 
The email address above is just as phony as it looks, and for obvious reasons.
Instant messaging contact nfo: AIM: evilDagmar  Jabber: evilDagmar at jabber.org

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list