Cdrecord problems...

Michael Brömer mib at telebel.de
Thu Jul 24 12:30:53 PDT 2003


Am Donnerstag, 24. Juli 2003 20:11 schrieben Sie:
> Hi all...
>
> I am trying to install cdrtools by following BLFS. I cut and pasted the
> commands. Here is the error...
>
> make[1]: Entering directory `/usr/src/source/cdrtools-2.0/scgcheck'
>         ==> COMPILING "OBJ/i686-linux-cc/scgcheck.o"
>         ==> COMPILING "OBJ/i686-linux-cc/sense.o"
>         ==> COMPILING "OBJ/i686-linux-cc/dmaresid.o"
>         ==> COMPILING "OBJ/i686-linux-cc/scsi_scan.o"
>         ==> COMPILING "OBJ/i686-linux-cc/scsi_cdr.o"
>         ==> COMPILING "OBJ/i686-linux-cc/cd_misc.o"
>         ==> COMPILING "OBJ/i686-linux-cc/modes.o"
>         ==> LINKING "OBJ/i686-linux-cc/scgcheck"
> /usr/bin/ld: kan ikke finde -lscg     (cannot find -lscg)
> collect2: ld returnerede afslutningskoden 1
> make[1]: *** [OBJ/i686-linux-cc/scgcheck] Fejl 1
> make[1]: Leaving directory `/usr/src/source/cdrtools-2.0/scgcheck'
> make: *** [all] Fejl 2
I am just guessing, you are running 2.6.0-test1, right? 
Then you had an earlier error during compilation. 
Search you logfile for:
 /usr/src/linux/include/scsi/scsi.h:229: error: parse error before "u8"

I ran into the same error with cdrtools-2.00.3.

> It says it cant find the scg lib (right?). Where can i find that one?
It is a part of the cdrtools, in the directory libscg

> I am using gcc-3.3, but i doubt that is the problem since i couldnt
> compile this program before i upgraded gcc-3.3 either. Cdrecord-1.10
> works fine with gcc-3.3 btw.
No it is a bug in cdrtools.

> Does anybody have an idea?
Insert "typedef unsigned char u8;" in scsihack.c in the
"ifdef linux"-section .

I made a patch for 2.00.3 but it should apply to 2.0 too.

Michael




-------------- next part --------------
A non-text attachment was scrubbed...
Name: cdrtools-2.00.3-2.6.0.patch.bz2
Type: application/x-bzip2
Size: 424 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20030724/7ccab1e8/attachment.bin>


More information about the blfs-support mailing list