Missing optional dependency for pango-1.2.3?

Matthew Burgess ca9mbu at hermes.sunderland.ac.uk
Sun Jul 6 15:33:11 PDT 2003


Background: Trying to run a freshly compiled version of eclipse-2.1.1
(http://www.eclipse.org) complains about a missing libpangoxft-1.0.so.0
library.

Investigation shows that this should actually be installed by a regular
compile of pango-1.2.3 but only if the ./configure script finds Xft2 at
compile time.  After installing Xft2 (http://fontconfig.org) using the
usual `./configure --prefix=/usr && make && make install` routine then a
recompile of pango-1.2.3 does indeed produce the required library and
hence enables eclipse to run in all it's GTK2 beauty :)

My question then - should pango-1.2.3 list Xft2 as an optional
dependency?

Thanks,

Matt.



-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list