Cannot execute /bin/bash: Permission denied

Albert Wagner alwagner at tcac.net
Fri Jul 4 02:31:17 PDT 2003


On Fri, 04 Jul 2003 12:04:47 +0200
Jeroen Coumans <jeroencoumans at gmx.net> wrote:
<snip>
> Ah, the same old problem. Try to check directory permissions? Did you 
> try to create a different user, to see if that one has the same
> problem?

Hi, Jeroen.  Thank you for replying.  Yes, I still have the same
problem.  Apparently, my installation of 4.0 was flawed in some way. 
That is, of course, my own fault.  However, I now only have this flawed
installation to leverage myself into a more kosher installation.  I
ignored this problem when going from 3.3 to 4.0 by simply doing the
complete installation of 4.0 as root.  I know this was dangerous and is
likely part/all of my current problem.

Checking, and where appropriate, changing permissions was the first
thing I did when I encountered the error.  I have also created a second
user named "myself" and get the same error.  To reiterate, the problem
is that I cannot login as a user other than root.  I have tried the
below two methods:

$ login

lfs4 login: lfs
Password: 
No mail.
Cannot execute /bin/bash: Permission denied

$ su - lfs
Cannot execute /bin/bash: Permission denied

The correct permissions for /bin/bash and /bin/su seem to be set:

$ la /bin/bash
-rwxr-xr-x    1 root     root       662926 Jan 18 06:03 /bin/bash

$ la /bin/su
-rwsr-xr-x    1 root     root        14136 Jan 18 06:03 /bin/su

I am therefore assuming that /bin/bash issues this message for reasons
it encounters during execution, e.g. sourceing a file with bad
permission, etc.

What I am asking therefore is:  What are the possible reasons for this
message, BESIDES the permissions on the /bin/bash executable?  I don't
have a clue where to begin solving this problem and was hoping for some
direction.  Any guidance whatsoever will be greatly appreciated.  Thanks
ahead.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list