OpenOffice-1.0.2 Complaines about gcc

R. Bosch Remy.Bosch at hccnet.nl
Wed Jul 2 13:29:40 PDT 2003


O.k.

A new thread for an old unresolved problem :-)

I'm trying to compile openoffice on a LFS-CVS from June 03-2003. As a
refference - for what it's worth - i'd like to note that mozilla-1.3 compiles
without problems. As the rest of BLFS, that I tried.
KDE/GNOME/GTK2 excluded ofcourse ;-)

To make some things clear I'll give you the programs I compiled/used.

  - gcc-3.2.3
      gcc-3.2.3-no_fixincludes.patch
      gcc-3.2.3-mmap_test.patch
  - glibc-2.3.2
  - binutils-2.13.2

  - expat-1.95.6-patched
  - mktemp-1.5
  - unzip550-fixed
  - zip23
  - which-2.14

  - XFree-4.3.0.1 (patch)

  - gpc231.zip
  - bison-1.75
  - tcsh-6.12.00
  - STLport-4.5.3
  - STLport-4.5.3-gcc3.patch
  

Patches used:
  - openoffice-1.0.2-add-pam-headers.patch
  - openoffice-1.0.2-bison-fix.patch
  - openoffice-1.0.2-cpputools-regcomp-makefile.patch
  - openoffice-1.0.2-dmake-clean.patch
  - openoffice-1.0.2-dont-build-mozab.patch
  - openoffice-1.0.2-dont-catch-segv.patch
  - openoffice-1.0.2-dont-uglify-html.patch
  - openoffice-1.0.2-dont-unset-home.patch
  - openoffice-1.0.2-errno-fix.patch
  - openoffice-1.0.2-honor-current-path.patch
  - openoffice-1.0.2-jdk1.4-syntax-fix.patch
  - openoffice-1.0.2-linux-test-bin-location.patch
  - openoffice-1.0.2-main-retval.patch
  - openoffice-1.0.2-mdk-asm-fixes.patch
  - openoffice-1.0.2-psprint-pdf-drivers.patch
  - openoffice-1.0.2-sal-main-cmdline.patch
  - openoffice-1.0.2-system-db-4.1.patch
  - openoffice-1.0.2-system-freetype-2.1.patch
  - openoffice-1.0.2-system-getopt.patch
  - openoffice-1.0.2-system-libXrender.patch
  - openoffice-1.0.2-system-nas.patch
  - openoffice-1.0.2-user-fontpath.patch


The commands are pretty much out of the book...


tar -xjf OOo_1.0.2_source.tar.bz2 &&
unzip gpc231.zip &&
cd oo_1.0.2_src/ &&
mv ../gpc231/* external/gpc &&
rm -rf ../gpc231 &&
for p in ../patches/openoffice-1.0.2-*.patch.bz2
do bzcat $p | patch -Np1
done &&

cd solenv/inc &&
cp unxlngi4.mk unxlngi4.mk.orig &&
sed -e "s:\-mcpu=pentiumpro::" \
unxlngi4.mk.orig > unxlngi4.mk &&
cd ../..

cd config_office/ &&
./configure --with-lang=ENUS --with-stlport4-home=/usr &&
cd .. &&
source LinuxIntelEnv.Set.sh &&
./bootstrap &&
dmake


And then it bails out...



I get this:
-----------------------------------------------------------------------------

=============
Building project product
=============
/media/source/extra/oo-102/oo_1.0.2_src/product/util
mkout -- version: 1.3
dmake:  makefile.mk:  line 503:  Error -- Detected circular dependency in
graph at [../unxlngi4.pro/bin/udk3.0.1/linux/lib/libstdc++.so.]---* RULES.MK
*---

ERROR: Error 65280 occurred while making
/media/source/extra/oo-102/oo_1.0.2_src/product/util dmake:  Error code 1,
while making 'build_all'---* TG_SLO.MK *---

-----------------------------------------------------------------------------

One question stands...
 - any new patches I don't know about?

Bug in gcc or openoffice?

Hope you can help me.
In case someone DOES take the effort to read the archive it's "us" ;-)



Greetings / Met vriendelijke groet,


Remy
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list