qt-3.1.0--libstdc++-libc6.2-2.so.3 is needed

Tushar T tush at yahoo.com
Fri Nov 29 11:22:33 PST 2002


Josh Hayes wrote:

>> From: J_Man <jeremy at jutley.org>
>> To: blfs-support at linuxfromscratch.org
>> Subject: Re: qt-3.1.0--libstdc++-libc6.2-2.so.3 is needed
>> Date: Fri, 29 Nov 2002 07:03:53 +0000 (UTC)
>>
>> In article <F156q9eSgN3OwecvbbI00008f8b at hotmail.com>, "Josh Hayes" wrote:
>> > I am VERY fusterated at this point. I'm try to install some 
>> apps/libs,(like
>> > QT), but they keep complaining that they need the file
>> > libstdc++-libc6.2-2.so.3
>> >
>> > I don't know how to get this file. I tried reinstalling gcc, but 
>> that didn't
>> > help. This is a Linux From Scratch v4.0
>> >
>> > "ls /usr/lib/libstdc++.*" yeilds the following:
>> >
>> > /usr/lib/libstdc++.a /usr/lib/libstdc++.so@ 
>> /usr/lib/libstdc++.so.5.0.0*
>> > /usr/lib/libstdc++.la* /usr/lib/libstdc++.so.5@
>>
>> Those apps are compiled with GCC 2.x, and will be binary incompatible 
>> with GCC
>> 3.x.  You'll need to get the source packages and build them from 
>> scratch.
>>
>> QT has instructions at http://beyond.us.linuxfromscratch.org - as for 
>> others,
>> try reading the README or INSTALL files included.
>
> But when I followed the instructions for QT from BLFS, I couldn't 
> compile it because it said it needed that file. Has anyone else had 
> this problem?

Please don't top post! Screws up responses.

How did you install the packages qt depends on i.e. X, libjpeg, libpng, 
...? Did you install them from source or did you use compiled packages?

-- 
Tushar Teredesai
LFS ID: 1377
http://tushar.lfsforum.org/

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list