libgnomeprint-1.116.1 - "undefined reference to 'deflate'"

James Drabb JDrabb at tampabay.rr.com
Thu Nov 28 08:07:18 PST 2002


Mason Staugler wrote:
> Dagmar d'Surreal wrote:
> 
>> On Wed, 2002-11-27 at 06:24, James Drabb wrote:
>>
>>
>>> I had this same error.  For some reason -lz was not beeing included on
>>> all gcc invocations.  You can edit the Makefile or do something like:
>>>
>>> CFLAGS="$CFLAGS -lz" CXXFLAGS="$CXXFLAGS -lz" make
>>>
>>> To compile everything.  Then do what you normally do for make install.
>>
>>
>>
>> Check the output of your configure script there and make sure you're
>> seeing:
>>
>> checking GP_LIBS... -Wl,--export-dynamic -lart_lgpl_2 -lpango-1.0
>> -lbonobo-2 -lbonobo-activation -lORBit-2 -lxml2 -lz -lm -llinc
>> -lgmodule-2.0 -ldl -lgobject-2.0 -lgthread-2.0 -lpthread -lglib-2.0
>>
>> It _should_ be picking up on the libz dependendency through the
>> pkgconfig file from libxml2.
>>
> 
> I got it to work by adding the -lz in the makefile when gcc is called. 
> So I moved on and got another deflate error when making gnome-panel. 
> I've already installed zlib according to the BLFS book (resolving a much 
> earlier dependency) but does this mean that something went wrong?
> 
> 

I don't think anythign went wrong.  I finished an LFS 4.0 system a few 
weeks ago and when I did gnome 2.0.1 I had the same problems with a few 
apps.  I just did an

export CFLAGS="$CFLAGS -lz"

Then all the compiles went fine.

Jim Drabb
-- 
---------------------------------------------------------------
Those who would sacrifice freedom for security will get neither
---------------------------------------------------------------
James Drabb JR
Programmer Analyst
Davenport, FL
JDrabb at tampabay.rr.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list