[Solved!] KDE-3.0.4 on blfs cvs 20021027

funnyhao at etang.com funnyhao at etang.com
Thu Nov 28 01:53:56 PST 2002


hi,

Please do forgive me for my rudeness,and thank you for the help offered to me.

I have entered the KDE today!I found that the problem is my locale. I use zh_CN.gbk and set XMODIFIERS to @im=gWuBi.When I unset all these enviroment variables, there are no problems now.

Since maybe there are only a few people from China have or will install BLFS,so related information is very limited.I'm now cooperate with my partner to translate the LFS Book into Chinese.Do you think the locale ware is very important for non-english people? I read all the hints but only found a french hint.In our country,and some others like Japan & Korea,the width of a word is two byte,so the hint is useless for me.I couldn't input Chinese words in KDE now.I will post a hint related to CJK locales only if I solved the problems.

At last,thank you again for your help!

Xinkui Hao

On Wed, 27 Nov 2002 09:29:16 +0100
Tim Holterhus <lfs at holterhus.com> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Wednesday 27. November 2002 08:32, Xinkui Hao wrote:
> > hi,
> >
> > I'm currently not subscribed to the list,so if you mind reply to
> > xinkuihao at yahoo.com .
> >
> > I'm building KDE-3.0.4 on my machine. I have successfully installed
> > XFree86-4.2.1, and use WindowMaker on it. When I compile
> > KDE-3.0.4,the first three packages,aRts,kdelibs,kdebase,seems all
> > right.But when I followed the direction of the book,type 'startx',and
> > I got following messages:
> >
> >
> [snip]
> > /opt/kde-3.0.3/bin/startkde: line 131: 15427 Segmentation fault kwin
> > /opt/kde-3.0.3/bin/startkde: line 131: 15428 Segmentation fault
> >    kpersonalizer --before-session DCOPServer up and running.
> [snip]
> > Since I don't set any CFLAGS or CXXFLAGS at all,so I'm curious of why
> > this happened.I couldn't download another copy of KDE like 3.0.3
> > because I'm using a modem to download everything. Have you encounted
> > this?
> 
> have you verified that the /opt/kde symlink, KDEDIR environment variable 
> and /etc/ld.so.conf all point to the right directory? It looks like 
> something is still pointing to your "old" 3.0.3 directory.
> 
> 	-Tim
> 
> - -- 
> The relative speed of a computer, regardless of CPU architecture, is
> inversely proportional to the number of Microsoft products installed.
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.7 (GNU/Linux)
> 
> iD8DBQE95IJcgoqahLHcQPQRAh7ZAJ9YS4dgTynlWnYJI+i89b9Z8tYp5wCeKhhM
> ObNfI5OVdLUs3YZdFFkbf1g=
> =vhcA
> -----END PGP SIGNATURE-----
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list