KDE-3.0.4 on blfs cvs 20021027

funnyhao at etang.com funnyhao at etang.com
Wed Nov 27 09:38:55 PST 2002



Date: Wed, 27 Nov 2002 17:20:52 +0000
From: <funnyhao at etang.com>
To: Tim Holterhus <lfs at holterhus.com>
Subject: Re: KDE-3.0.4 on blfs cvs 20021027


Hi,

Firt of all, thank you for reply to my email address.

I didn't install KDE-3.0.3 at all.I use the symlink simply to facilitate my copy & paste of those commands from BLFS BOOK.When I downloading the KDE packages,3.0.4 was already out.I suppose the BOOK will catch up,but till now it havn't.Maybe they're waiting for 3.1 which will out soon.

After two days of compiling and recompiling,I found that maybe the problem isn't the building process itself.Because I can use Konqueror and many other tools provided by kdebase in windowmaker,without any problem.But when I exec startkde,things go wrong.Maybe it need some more configuration? I don't know PAM or xinted or something else need to be done.I've search out the mailing-list archive,but found curiouly it seems that only me encountered such a problem. Have you done some configuration out of BLFS BOOK?

Xinkui Hao

On Wed, 27 Nov 2002 09:29:16 +0100
Tim Holterhus <lfs at holterhus.com> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Wednesday 27. November 2002 08:32, Xinkui Hao wrote:
> > hi,
> >
> > I'm currently not subscribed to the list,so if you mind reply to
> > xinkuihao at yahoo.com .
> >
> > I'm building KDE-3.0.4 on my machine. I have successfully installed
> > XFree86-4.2.1, and use WindowMaker on it. When I compile
> > KDE-3.0.4,the first three packages,aRts,kdelibs,kdebase,seems all
> > right.But when I followed the direction of the book,type 'startx',and
> > I got following messages:
> >
> >
> [snip]
> > /opt/kde-3.0.3/bin/startkde: line 131: 15427 Segmentation fault kwin
> > /opt/kde-3.0.3/bin/startkde: line 131: 15428 Segmentation fault
> >    kpersonalizer --before-session DCOPServer up and running.
> [snip]
> > Since I don't set any CFLAGS or CXXFLAGS at all,so I'm curious of why
> > this happened.I couldn't download another copy of KDE like 3.0.3
> > because I'm using a modem to download everything. Have you encounted
> > this?
> 
> have you verified that the /opt/kde symlink, KDEDIR environment variable 
> and /etc/ld.so.conf all point to the right directory? It looks like 
> something is still pointing to your "old" 3.0.3 directory.
> 
> 	-Tim
> 
> - -- 
> The relative speed of a computer, regardless of CPU architecture, is
> inversely proportional to the number of Microsoft products installed.
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.7 (GNU/Linux)
> 
> iD8DBQE95IJcgoqahLHcQPQRAh7ZAJ9YS4dgTynlWnYJI+i89b9Z8tYp5wCeKhhM
> ObNfI5OVdLUs3YZdFFkbf1g=
> =vhcA
> -----END PGP SIGNATURE-----
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list