XFree86 -configure (libpam) - REPOST

Brian Auld bauld at hotpop.com
Mon Nov 25 06:47:54 PST 2002


Thanks for the reply.

I've been compiling typically in a 'host system boot' chrooted to the
lfs environment, as opposed to a direct boot into lfs. I realized
(in my sleep last night possibly) that I did not reboot after all the
partition doctoring I performed. I went straight to chroot lfs and
recompiled XFree86.

This compile ultimately led to the libpam error when running
-configure (which Ihave been doing as root ... root is in fact the
only user currently in my lfs environment, so it would be hard to be
anyone else).

I thought to myself .... *&%$# it, reboot into lfs and then re-compile.
Note, this was my first reboot since the "partition expansion exercise".
When I tried to boot into lfs, I got some kind of bash error that shot
across the screen and returned me to the login prompt ... time and
time again. In other words, I can't login. I'm at work now, so I can't
say for sure if it was a problem with bash, or some other error
message that simply had bash in the message since its the shell I'm
using.

It would appear to me that the issue now is a little larger than getting
XFree86 to work.

(1) Host system now shaky
====================
My host system can no longer mount my /home partition. The '/',
'/usr/', '/var' and '/boot' partitions are fine. Interesting thing is that
it
was the '/usr' partition I shrank on the host system to create room
for the lfs '/usr' partition ( /mnt/lfs/usr from the host perspective).

Before the parition exercise, my host '/usr' and '/home' were adjacent
to each other. '/usr/', had a lot of unused space, so I shrank it to half
it's size leaving ~1.5GB of unused space between the end of the
'/usr' and beginning of the '/home' partitions. This is where my lfs
'/usr' partition was created.

I noticed that fdisk does not maintain hda* labels if you shrink a
partition to add another. After resizing the host '/usr' partition to
half its original size, I then had to delete it and re-add it in fdisk
to actually shrink the parition. When I first deleted the host '/usr'
partition (which was hda5 of hda5 -> hda10 linux partitions), all
of the partitions with higher lables were decremented by 1
so that I now had hda5 -> hda9 with free space where the host
'/usr' used to be. At this point I figured I had 2 choices:

   a) add the newly resized host '/usr' parition followed by the
        brand spanking new lfs '/usr' parition ....and then relabel
        my /etc/fstab disk labels so that they are consistent with
        the new disk labels.
                                           or

   b) while in fdisk (and before writing the changes to disk),
        delete all paritions and then re-create so I can maintain
        the correct disk labels. When I recreate, everything would
        be as it was before, except the host '/usr' would have
        been resized to half its original size, and a new lfs '/usr'
        partition would sandwiched between the host '/usr' and
        '/home'.

Oh, also, this was not all intuition as I was referring to the fdisk,
mke2fs, resize2fs and tune2fs man pages as I proceeded.

In my infinite wisdom I chose (b) above. I will spare you on all
the gory details, but when all was said and done, everything
seemed to work except that I had an error on /dev/hda6 ....
my original (and unchanged) host '/home' partition when I
rebooted. I tried all sorts of recsue attempts using e2fsck as
per man pages ... but eventually came to the conclusion that
my host '/home' partition was screwed.

(2) Can't boot into lfs
================
As mentioned above, I can't boot into my lfs system.

(3) What next??
============
Now that I'm unable to use Xwindows on my host system, my
priority of getting XFree86 working on LFS raised itself in its
priority. The suggestion below was to reinstall XFree86 again
but I'm afraid I'll just be repeating the same step again. First,
I need to find out what the $%^&* is wrong with my computer.
On the host as well as lfs side.

Any suggestions would be appreciated.

I don't know if I was asking any legitimate questions or just
recouting the amazingly enjoyable Sunday I spent locked in my
room 'trying to fix a hose that seem to get more and more holes
in it every time I try to fix something' ... the host being my
computer of course :-)

Question: If I do end up having to reinstall lfs stuff and I don't
have Xwindows support on the host side, are there any nifty
ways of automated the installation process without having to
manually type all the command in from the lfs/blfs book. I can't
see how I wouldn't make a spelling error if I had to do it this
way.

-- Brian


Bruce Dubbs wrote:

> Brian Auld wrote:
>
> > I didn't mention it earlier, but I presume that the XFree86 -configure
> > command is supposed to be run from lfs and not the host system.
> >
> > I might sound like an obvious question, but at this point I'm pulling
> > at straws.
>
> Did you compile in a chroot or while booted into lfs?  There should be
> no reference to pam, so I would suspect it was picked up somehow from
> your host distro.
>
> I recommend starting over and compiling from your lfs system.  XFree86
> -configure creates a XF86Config.new file for you.  You need to be root
> to run it.
>
>   -- Bruce
>
> --
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe blfs-support' in the subject header of the message


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list