XFree86 -configure (libpam) - REPOST

Brian Auld bauld at twcny.rr.com
Sun Nov 24 19:42:18 PST 2002


Sorry about that ... Hopefully this will be more readable.

My linux box is hosed to the point where I have to use outlook to send this
message, so I hope the format is alright. I'm trying to wrap it appropriately.

The XFree 86 saga continues.

(1) Over the past week, I've eventually stumbled my way through the compilation
process to get XFree86 to build. Mulitple compile errors I fixed as I trudged along.

(2) The first time I ran "XFree86 -configure" I got an error message about not finding
 ''/usr/X11R6/lib/rgb'. The suggestion from this mailing list was a potential disk 
space deficiency that the build process wasn't really telling me about.

(3) I took this to heart and proceeded to expand my space available to LFS by 
created another lfs partition (/usr -> about 1.5BG). I intially just had a root partition 
of 2GB. So, now I have a root partition of 2GB and a /usr partition of 1.5GB. I figured 
this would be enough disk space for XFree86 and then some.

(4) So, I did a fresh upack of the XFree86 tarballs and recompiled/reinstalled from
 scratch. Now when I run "XFree86 -configure" I get the following message:

"XFree86:error while loading shared libraries: libpam.so.0: cannot open shared 
object file"

Is this a library that we were supposed to install?? I did have to do some 
housekeeping when I created the new /usr partition, but why would I lose a library? 
To create the new parition I did a:

- "mv /usr /user"
- "mkdir /usr"
- "mount /dev/hda* /usr"
- "cd /user"
- "cp -R * /usr"

Any advice would be appreciated. In the mean time, I guess I'll try and find out about 
libpam and see if I can get it installed. I see it on my host system but not lfs 
system.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20021124/1be66d45/attachment.html>


More information about the blfs-support mailing list