"XFree86 -configure" error

Dagmar d'Surreal dagmar at speakeasy.net
Sat Nov 23 22:57:58 PST 2002


On Sat, 2002-11-23 at 22:51, Brian Auld wrote:
> I was going through the XFree86 post-compile (successful!!) steps
> in the BLFS book and encountered an error when running 'XFree86 -configure'.
> It appears that its looking for rgb in '/usr/X11R6/lib/X11/rgb', but pukes
> when it finds that that file is not there:
> 
> root:/usr/src/xc# ls /usr/X11R6/lib/X11
> XErrorDB  XKeysymDB  config  locale

*shudder*  There should be a lot more in there than that.

> root:/usr/src/xc#
> 
> I also attached the file '/var/log/XFree86.0.log'.
> 
> I basically compiled XFree86 as the per the book. I went through a few
> iterations of recompiling due to missing ';' errors in '.y' files. I did
> a make clean and recompiled and consistently get this error message now.

1.  make clean doesn't do much for XFree86.  In fact, unless you are
ordering it to only build a specific chunk of stuff, it'll be very
stubborn about spending 15 minutes just running around deleting and
remaking symlinks and such.

2.  Offhand I'd say that at some point you ran out of disk space. 
Delete your source tree for Xfree86 (I said _delete_, _not_ make clean)
and untar tarballs 1 & 2 again (and three if you want to be persnickety
about documentation) and try one more time, making sure you have PLENTY
of free space in /usr when you do... by PLENTY I mean 500Mb or so at
least, but preferably a Gb.  XFree86's build scripts are _not_ bright
enough to notice they've used up all the disk space and will merrily
plod along chewing up clockcycles for nothing right to the end without
so much as a whimper provided they managed to build the base objects the
other things are being linked with.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list