CUPS Re-installation fails

Richard A Downing richard.downing at bcs.org.uk
Tue Nov 19 08:26:14 PST 2002


On Tuesday 19 November 2002 14:50, you wrote:
> On Tuesday 19 November 2002 03:34 am, Chris Lingard wrote:
> > Richard A Downing wrote:
...
> > > I deleted (I think - I used GIT) all the files installed by
> > > cups-1.1.15, espgs-7.05.5, and gimp-print-4.2.3.  Then I rebuilt the
> > > three packages from sources, in this order, configuring as follows:
> > > 1) espgs-7.05.5  ./configure --prefix=/usr --with-gimp-print --with-x
> > > 2) cups-1.1.15 ./configure
...

Thanks Matt and Chris.
The answer (since ghostscript worked fine - I even remembered to install the 
fonts this time !) was the order of compilation.

Cups MUST be installed before ESP Ghostscript otherwise espgs's configure 
doesn't find cups-config and assumes you don't need pstoraster.  Hence cups 
can't convert postscript to raster with gs.

Then install the Gimp-print, and in my case since we don't have zgrep (which I 
think grep's gziped files - next thing to look into...) needs  
--without-translated-ppds otherwise you get about 50 ppds for each printer.

Before the flames ... I must talk to the CUPS-printing hints owner about an 
update....

All the best,
Richard.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list