LPRng install

Fergus Belford fbmail at ozemail.com.au
Fri Nov 15 06:56:31 PST 2002


and thus did Fergus Belford intone:
> 
> Attempting to install LPRng-3.8.15, using these commands:
> 
> ./configure --prefix=/usr --sysconfdir=/etc \
> --disable-setuid --disable-gdbm &&&
> make &&
> make install
> 
> Make fails with the following:
> 
> echo "#define " SSL_SERVER_PASSWORD_FILE
> \"/etc/lpd/ssl.server/server.pwd\" >>defs.h
> gcc -s -I.. -I. -I./include -I./common -w -I/usr/include  -g -W -Wall
> -Werror -Wno-unused   -g -W -Wall -Werror -Wno-unused  -DHAVE_CONFIG_H
> -c -o lpc.o ./common/lpc.c
> cc1: changing search order for system directory "/usr/include"
> cc1:   as it has already been specified as a non-system directory
> make[1]: *** [lpc.o] Error 1
> make[1]: Leaving directory `/usr/src/LPRng-3.8.15/src'
> make: *** [src] Error 2
> 
> Tried adding CPPFLAGS=-w before ./configure, but made no difference at
> all.  Tried that 'cause it fixed imlib install problem of same nature.
> 
> Can anyone help, please?
> 
> --
> Fergus Belford
> --
> "I hate quotations. Tell me what you know." - Ralph Waldo Emerson

Fixed the problem.  Found "a" solution (which doesn't seem at all
elegant, to me) on a mailing list some where:

remove all instances of "-I/usr/include" from compiler-flags in
"./po/Makefile" and "./src/Makefile".

Now make && make install run cleanly
-- 
Fergus Belford
-- 
"People think Microsoft is the answer. 
Microsoft is the question, "No" is the answer."
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list