(no subject)

drharlan at pacbell.net drharlan at pacbell.net
Tue Nov 12 13:12:59 PST 2002


Please respond to email address - not subscribed to list.

I have a persistent problem getting XFree86 to compile.  I seems to
finish the make World part but up in the body of the log file, I see
the Error 1 where apparently some character is missing.  I have applied
the 4.2.0-4.2.1 patch, the 4.2.1 security patch and the bison patch.  I
have bison-1.75.  I have started with a fresh tree each time, and I'm
using the parallel build directory which I created using the lndir
command.

I then tried to do a make install, but it stops at the same point where
it tries to do the same thing with the same resultant error.

--start section of log file with error--

gcc -c -O2 -fomit-frame-pointer -march=i686 -ansi -pedantic -pipe   -fno-merge-constants -I../include -I../../../exports/include/X11 -I../../../include/fonts -I../../../include/extensions 	       -I../../../programs/Xserver/Xext -I../../../programs/Xserver/lbx  -I../../.. -I../../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_SOURCE -D_SVID_SOURCE  -D_GNU_SOURCE  -DSHAPE -DXINPUT -DXKB -DLBX -DXAPPGROUP -DXCSECURITY -DTOGCUP  -DXF86BIGFONT -DDPMSExtension  -DPIXPRIV -DPANORAMIX  -DRENDER  -DGCCUSESGAS -DAVOID_GLYPHBLT -DPIXPRIV -DSINGLEDEPTH -DXFreeXDGA -DXvExtension -DXFree86LOADER  -DXFree86Server -DXF86VIDMODE -DXvMCExtension  -DSMART_SCHEDULE -DBUILDDEBUG -DX_BYTE_ORDER=X_LITTLE_ENDIAN -DNDEBUG  -DFUNCPROTO=15 -DNARROWPROTO     -DCOMPILEDDEFAULTFONTPATH=\"/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,	/usr/X11R6/lib/X11/fonts/100dpi/,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/local,	/usr/X11R6/lib/X11/fonts/TrueType,
gcc: /usr/X11R6/lib/X11/fonts/100dpi/,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/local,: No such file or directory
gcc: /usr/X11R6/lib/X11/fonts/TrueType,/usr/X11R6/lib/X11/fonts/CID,/usr/X11R6/lib/X11/fonts/Speedo": No such file or directory
<command line>:1:25: missing terminating " character
make[5]: *** [globals.o] Error 1

--- much snipped ---

make[5]: Leaving directory `/mnt/install/XFree86/build/doc/man/GLU'
make[4]: Leaving directory `/mnt/install/XFree86/build/doc/man'
make[3]: Leaving directory `/mnt/install/XFree86/build/doc'
make[2]: Leaving directory `/mnt/install/XFree86/build'
make[1]: Leaving directory `/mnt/install/XFree86/build'

Tue Nov 12 12:21:43 PST 2002

Full build of Release 6.6 of the X Window System complete.

--end of log file--

Thanks for any help

Wayne


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list