USB dead after frequent hot-plugging

Simon Roby shamblrd at hotmail.com
Mon Nov 4 06:59:31 PST 2002


----- Original Message -----
From: "Joe Morris" <heartboy at nycap.rr.com>
To: <blfs-support at linuxfromscratch.org>
Sent: Sunday, November 03, 2002 6:48 PM
Subject: USB dead after frequent hot-plugging


Hey guys! I've got a Via USB 2.0 controller on my mobo.  I've got the
ehci-hcd
driver compiled into the kernel (I've tried modules as well, used both
2.4.19
and 2.4.20-pre9).  When something is plugged into a USB 2 port at boot it
all
runs okay. If I hot-plug something, I can run dmesg and see it is detected.
However, after frequent plugging and unplugging, it seems the ports go
'dead'.  I've tried compiling ehci-hcd as a module and reinserting the
module
when it goes dead, but that doesn't work.  I tried plugging in my laser
mouse
into the USB 2, and I see it light up for a brief second, but then power
stops going to it and it never gets detected after this 'dead' period.  As I
said before, if I have it plugged in at boot there is no problem.  The USB
1.1 ports work perfectly as well.  Is this a problem with the kernel driver
do you think? Can you think of any work-arounds? HELP! Thanks!
Joe

USB 2.0 support is still EXPERIMENTAL, so don't be so surprised that stuff
doesn't work perfectly.
BTW, you should read the ehci documentation supplied with the kernel source,
it discusses some issues with the USB 2.0 driver.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list