graphics acceleration

Simon Roby shamblrd at hotmail.com
Mon Nov 4 06:45:25 PST 2002


----- Original Message -----
From: "Jochen Schröder" <jschrod at uni-muenster.de>
To: <blfs-support at linuxfromscratch.org>
Sent: Sunday, November 03, 2002 12:13 PM
Subject: Re: graphics acceleration


> Bruce Dubbs wrote:
> > Jochen Schröder wrote:
> >
> >> Hi guys,
> >> I just noticed something odd. I ran glxgears on my host (SuSE 8.0) and
> >> my lfs (cvs from end of september) system and on my host it runs with
> >> ~3000 FPS on my lfs it runs with ~1880 FPS. I'm using the Nvidia
> >> Driver on both systems, the one on the lfs is a newer version. Could
> >> there be other reasons for the difference than the different drivers?
> >> Usually I'd
> >> expect the newer driver to be faster.
> >> Any ideas anybody?
> >
> >
> > The only thing I can think of is optimizations in the drivers or X
itself.
> >  -- Bruce
> >
> I thought of this as well, must be X then, optimization wont have much
> effect on the nvidia driver considering that the module is binary, I
> guess. Maybe I'm going to compile X with less optimization next time, I
> used '-O3 -march=athlon-xp -msse -mfpmath=sse -fomit-frame-pointers'
> maybe the O3 is actually slowing the X-server down.
> Cheers
> Jochen
>

Yes, the problem is most likely the O3 flag. There has been a discussion on
that recently on the mailing list, and the conclusion is basically: O3 is
_evil_, never use it!
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list