USB dead after frequent hot-plugging

Joe Morris heartboy at nycap.rr.com
Sun Nov 3 15:48:07 PST 2002


Hey guys! I've got a Via USB 2.0 controller on my mobo.  I've got the ehci-hcd 
driver compiled into the kernel (I've tried modules as well, used both 2.4.19 
and 2.4.20-pre9).  When something is plugged into a USB 2 port at boot it all 
runs okay. If I hot-plug something, I can run dmesg and see it is detected.  
However, after frequent plugging and unplugging, it seems the ports go 
'dead'.  I've tried compiling ehci-hcd as a module and reinserting the module 
when it goes dead, but that doesn't work.  I tried plugging in my laser mouse 
into the USB 2, and I see it light up for a brief second, but then power 
stops going to it and it never gets detected after this 'dead' period.  As I 
said before, if I have it plugged in at boot there is no problem.  The USB 
1.1 ports work perfectly as well.  Is this a problem with the kernel driver 
do you think? Can you think of any work-arounds? HELP! Thanks!
Joe
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list