USB mouse under X

steven stimpson steven2 at gwi.net
Sun Nov 3 10:38:54 PST 2002


In article <200211031014.59953.matt at matt.rogers.name>, matt at matt.rogers.name (Matt Rogers) wrote:
>On Sunday 03 November 2002 09:46 am, David C wrote:
>> Hi all...
>>
>> I can't seem to get my USB mouse to work for some reason. I followed th=
>e
>> USB Mouse hint, and when I plug in my USB Mouse, I do get the kernel
>> message indicating it was recognized.
>>
>> I compiled the necessary support into my kernel, and even installed GPM=
>,
>> but my mouse won't work in the console nor in X. I did alter the
>> /etc/X11/XF86Config-4 where needed, comparing it to both the USB Mouse
>> hint and to my RH 8.0 hosts' config file.
>>
>> So far all I've done beyone the base CVS LFS system is to replace
>> bison-1.75 with bison-1.35, install openssl, lynx, xfree86-4.2.0 with
>> 4.2.1 patch, freetype2, and GPM, along with the configurations
>> specified in the books.
>>
>> In /dev I have a symlink from mouse to input/mice as specified, and the
>> input/mice file was created using:
>>
>> mknod /dev/input/mice c 13 63
>(snip)
>
>> Section "InputDevice"
>> =09Identifier  "USB Mice"
>> =09Driver      "mouse"
>> =09Option=09    "Protocol" "IMPS/2"
>> =09Option=09    "Device" "/dev/input/mice"
>>         Option      "ZAxisMapping" "4 5"
>>         Option      "Emulate3Buttons" "no"
>> EndSection
>>
>> Section "Monitor"
>>         Identifier   "Monitor0"
>>         VendorName   "KDS"
>>         ModelName    "Xtreme Flat"
>>         HorizSync   30-96
>>         VertRefresh 50-160
>>         Option "dpms"
>> EndSection
>(snip)
>> in my modules.conf because it was in my hosts' and I thought it would b=
>e
>> needed. Still USB support didn't work with OR without it, and still
>> doesn't. I'm at a loss here. I've tried comparing anything that might
>> be related to my host system but still no luck.
>>
>> Can someone please, please help me? I've been working at this all night
>> and I'm stumped and frustrated. If it helps, I have attached my kernel
>> .config file. One odd thing is any USB related options I selectes as
>> "y" except for USB printer and perhaps mass storage, yet I notice now
>> that the config file has a couple others listed as "m". Wierd...
>>
>> Thanks,
>
>
>I would try changing the protocol setting to "Auto" or "usb" and see if o=
>ne of=20
>those fixes your problem.  Also check out=20
>http://www.xfree86.org/4.2.0/mouse.html for some more info on mice with X=
>=2E=20
>
>Matt
>
>
I use a USB Keyboard and a USB Mouse under LFS But I have to use the 2.4.18 
kernel. when I use the exact same settings to setup my USB devices under the 
2.4.19 kernel everything is dead and I don't know why. Maybe you could quickly 
try a 2.4.18 kernel if it wouldn't be too much of a bother?
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list