USB mouse under X

Matt Rogers matt at matt.rogers.name
Sun Nov 3 08:14:59 PST 2002


On Sunday 03 November 2002 09:46 am, David C wrote:
> Hi all...
>
> I can't seem to get my USB mouse to work for some reason. I followed the
> USB Mouse hint, and when I plug in my USB Mouse, I do get the kernel
> message indicating it was recognized.
>
> I compiled the necessary support into my kernel, and even installed GPM,
> but my mouse won't work in the console nor in X. I did alter the
> /etc/X11/XF86Config-4 where needed, comparing it to both the USB Mouse
> hint and to my RH 8.0 hosts' config file.
>
> So far all I've done beyone the base CVS LFS system is to replace
> bison-1.75 with bison-1.35, install openssl, lynx, xfree86-4.2.0 with
> 4.2.1 patch, freetype2, and GPM, along with the configurations
> specified in the books.
>
> In /dev I have a symlink from mouse to input/mice as specified, and the
> input/mice file was created using:
>
> mknod /dev/input/mice c 13 63
(snip)

> Section "InputDevice"
> 	Identifier  "USB Mice"
> 	Driver      "mouse"
> 	Option	    "Protocol" "IMPS/2"
> 	Option	    "Device" "/dev/input/mice"
>         Option      "ZAxisMapping" "4 5"
>         Option      "Emulate3Buttons" "no"
> EndSection
>
> Section "Monitor"
>         Identifier   "Monitor0"
>         VendorName   "KDS"
>         ModelName    "Xtreme Flat"
>         HorizSync   30-96
>         VertRefresh 50-160
>         Option "dpms"
> EndSection
(snip)
> in my modules.conf because it was in my hosts' and I thought it would be
> needed. Still USB support didn't work with OR without it, and still
> doesn't. I'm at a loss here. I've tried comparing anything that might
> be related to my host system but still no luck.
>
> Can someone please, please help me? I've been working at this all night
> and I'm stumped and frustrated. If it helps, I have attached my kernel
> .config file. One odd thing is any USB related options I selectes as
> "y" except for USB printer and perhaps mass storage, yet I notice now
> that the config file has a couple others listed as "m". Wierd...
>
> Thanks,


I would try changing the protocol setting to "Auto" or "usb" and see if one of 
those fixes your problem.  Also check out 
http://www.xfree86.org/4.2.0/mouse.html for some more info on mice with X. 

Matt


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list