error compiling X

David C david at desolateonline.com
Sat Nov 2 10:02:06 PST 2002


On Saturday 02 November 2002 07:41 am, you wrote:

>
> David,
>
> Did you try and follow the xfree86+freetype.txt hint?  I just
> finished and the hint works well.  I would rm -Rf xc/ and untar
> the source again to start with a clean build and follow the hint to
> tee.
>
> Jim Drabb

Still no joy. I tried again, this time using the xfree86+freetype.txt 
hint from within my native LFS environment rather than chroot. The only 
deviation I made from the hint is I used XFree86-4.2.0 and the 4.2.1 
diff patch instead of the older version the hint uses. I also added 
-fomit-frame-pointer to the hints suggested optimizations, hoping to 
reduce the size a bit and perhaps speed up compile some too. Once again 
I cannot even get past make World now. 

This is my third try. The first try gave the error mentioned in the 
original post, during the make install phase, though make World gave no 
errors. The second try and now this third try bomb out in make World 
with the following error:

make[3]: Leaving directory `/usr/src/xc/lib/Xrender'
depending in lib/Xft...
make[3]: Entering directory `/usr/src/xc/lib/Xft'
flex -l  xftlex.l
sed 's/yy/XftConfig/g' lex.yy.c | sed 's/__REALLY_YY__/yy/' > xftlex.c 
&& rm -f lex.yy.c
bison -y -d xftgram.y
xftgram.y:168.8: parse error, unexpected ":", expecting ";" or "|"
xftgram.y:169.3-6: $$ of `matrix' has no declared type
make[3]: *** [xftgram.c] Error 1
make[3]: Leaving directory `/usr/src/xc/lib/Xft'
make[2]: *** [depend] Error 2
make[2]: Leaving directory `/usr/src/xc/lib'
make[1]: *** [depend] Error 2
make[1]: Leaving directory `/usr/src/xc'
make: *** [World] Error 2

Any idea what can be causing this? Could the line with 'parse error' in 
it indicate a typho somewhere? Or the next line about matrix having no 
declared type - bug in source code? I highly doubt it's either of 
these, since it obviously must work for most everyone else. It even 
worked for me on my last LFS install (the cvs version that was 
basically equal to the as yet unreleased LFS 4.0)

Could it be something I have failed to install or installed incorrectly? 
So far I haven't done much past the LFS book, just the first few pages 
of BLFS dealing with config files and such. I do have Freetype 
installed though, but that's it beyond LFS.

I really hope someone can help me with this, as it's keeping me in limbo 
here til I get it fixed. Thanks in advance folks...

-- 
David C.
Linux user #277013
david at desolateonline dot com


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list