Crash building RPM 4.0

Chris Lingard chris at stockwith.co.uk
Mon Oct 29 11:38:56 PST 2001


Ripalda-Marin, Miguel-Angel wrote:

> Hi everybody,
> 
> This problem that I have looks similar to the one about XFree86 4.0.2 that
> I have just posted a few minutes before...
> 
> I'm using the LFS Hint for installing RPM 4.0 on my LFS 3.0 box, and
> I'm getting some problem that forces it to crash when building it. I have
> no problem compiling sources for zlib 1.1.3, gnupg 1.0.4 and db3 3.1.17...
> the problem (I don't include the whole ouput) comes up when I try to
> 'make' the RPM 4.0 sources and it looks like this:
> 
> make
> ...
> gcc ... .libs/popt.lo
> Error in function 'poptGetNextOpt'
> 'FLT_MAX' undeclared
> 'FLT_MIN' undeclared

Add the line

#include <values.h>

either into the program, or one of its local include files.

Chris
> 
> that doesn't make much sense for my.... and I would like to compile that
> app... so, anyone would be so kind to help me?
> 
> Thanks in advance and best regards,
> 
> Miguel Ángel Ripalda Marín
> Siemens Elasa S.A.
> T, I + D Sistemas
> Pol. Malpica, D-98 50016 Zaragoza, España
> Phone:        (34) 976 760 300 ext. 451
> Fax:          (34) 976 760 346
> E-Mail:       maripalda at elasa.siemens.es

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list