NFS-mounting goes BAD :-(

NIVET Rémi remi.nivet at atosorigin.com
Mon Oct 29 07:04:28 PST 2001


Tell me if I'm wrong but it looks like you try to mount / from your
server but you only exports /usr.

Rémi.

On Mon, 2001-10-29 at 12:28, R. Bosch wrote:
> Hi,
> 
> As compiling goes well on my LFS-boxes, setting up NFS, is a B*tch :-(
> I followed the directions of the nfs-hint, but I cannot get it to work. In a 
> attempt of final desperation, I like to hear your opinions about my 
> config-files.
> 
> Note: I can telnet back and forth, so that sould leave only the nfs-config 
> stuff to adjust. Nontheless I'll post them with the rest of then 
> network-stuff to have a complete view on the matter.
> 
> As you can see, there's no regards to security what so ever :-P
> 
> Here is from server: (192.168.99.1)
> ----------------------------------------------------
> hosts
> ----------------------------------------------------
> 127.0.0.1       localhost       localhost
> 192.168.99.1    LFS-server      LFS-server
> 192.168.99.200
> 
> ----------------------------------------------------
> hosts.allow
> ----------------------------------------------------
> ALL : 127.0.0.1
> ALL : 192.168.99.1
> ALL : 192.168.99.200
> 
> ----------------------------------------------------
> hosts.deny
> ----------------------------------------------------
> ALL : ALL
> 
> ----------------------------------------------------
> exports
> ----------------------------------------------------
> /usr    (rw)
> 
> ----------------------------------------------------
> starts with...
> ----------------------------------------------------
> /sbin/portmap
> rpc.mountd
> rpc.nfsd 8
> rpc.statd
> 
> 
> ####################################################
> 
> 
> Here is from the client (192.168.99.200)
> ----------------------------------------------------
> hosts
> ----------------------------------------------------
> 127.0.0.1       localhost       localhost
> 192.168.99.200  LFS-station     LFS-station
> 192.168.99.1
> 
> ----------------------------------------------------
> hosts.allow
> ----------------------------------------------------
> ALL : 127.0.0.1
> ALL : 192.168.99.1
> ALL : 192.168.99.200
> 
> ----------------------------------------------------
> hosts.deny
> ----------------------------------------------------
> ALL : ALL
> 
> ----------------------------------------------------
> starts with...
> ----------------------------------------------------
> /sbin/portmap
> /usr/sbin/rpc.statd
> 
> 
> When I try to mount the server:
> [root:~ # mount 192.168.99.1:/ /floppy/]
> 
> Then I get:
> [mount: 192.168.99.1:/ failed, reason given by server: Permission denied]
> 
> This leads me to the question why I can't mount when I give permission...???
> 8-O
> 
> Thanks in advance!
> 
> -- 
> Houdoei!
> 
> Remy
> 
> ---------------------------------
> > Proud to be Micro$oft free !!!
> > What's to learn from an OS that
> > does everything for you ?
> ---------------------------------
> -- 
> Unsubscribe: send email to listar at linuxfromscratch.org
> and put 'unsubscribe blfs-support' in the subject header of the message


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list