Samba bootscript problem

Menno Boer mboer at dds.nl
Sat Oct 27 07:38:46 PDT 2001


well.. AFAIK, samba is installed 9via the hint in /usr/local/sbin ergo...
change the paths.. that should do the trick...


Menno Boer
"Sanjuro Europe" <sanjuro_e at yahoo.com> wrote in message
news:3BDABF14.50109 at yahoo.com...
> I upgraded my 3.0-pre4 system with the 3.0 bootscripts, but for some
> reason one of my custom bootscripts doesn't work anymore. The error
> message says that the files can't be found.
>
> I attached the file. What is the problem? May be something with the "'s?
>     But how do I replace them?
>
> Sanjuro
>


----------------------------------------------------------------------------
----


> #!/bin/sh
>
> source /etc/rc.d/init.d/functions
>
> case "$1" in
>     start)
>         echo -n "Starting smbd..."
>         loadproc "/usr/local/samba/bin/smbd -D"
> echo -n "Starting nmbd..."
>         loadproc "/usr/local/samba/bin/nmbd -D"
>         ;;
>
>     stop)
>         echo -n "Stopping smbd..."
>         killproc smbd
> echo -n "Stopping nmbd..."
>         killproc nmbd
>         ;;
>
>     restart)
>         $0 stop
>         sleep 1
>         $0 start
>         ;;
>
>     status)
>         statusproc smbd
>         statusproc nmbd
>         ;;
>
>     *)
>         echo "Usage: $0 {start|stop|restart|status}"
>         exit 1
>         ;;
> esac
>


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list