Help with LILO Fatal Error

qwer qwerr mylfs21 at hotmail.com
Tue Oct 23 21:29:00 PDT 2001


I am new at linux and I decided to try LFS so that I would learn more.

My problem is when I run /sbin/lilo, I get the error:

Fatal: First boot sector is version 21.4.  Expecting Version 21.7.


Some background:

I installed LFS from Redhat 7.1
The new LFS 3.0 system would work perfectly, including LILO.

As a typical newbie, I logged in as root on the Redhat system with GNOME as 
my window manager, which is very unstable.  As I logged out, it crashed the 
system and I could not get back into X.  As I don't know much about Linux, I 
decided to save time and re-install redhat linux and consequently 
reformatted the /boot partition.

After the installation I changed the /etc/lilo.conf so that I could boot lfs 
and use the Redhat kernel (The LFS kernel was wiped out when /boot was 
reformatted)

I can now boot LFS, I then Compiled a new Kernel (Version 2.4), and then 
tried to use LILO, but I get the error described above.  I had to use the 
version in Redhat linux, which still works.

This is the first time I have asked for help, so it would be great if I 
could also have some feedback on how I asked (for example, did I come to the 
right place,)  Thankyou

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list