Xdm and startx

Craig Colton meerkats at bellsouth.net
Tue Oct 23 19:24:07 PDT 2001


On Monday 22 October 2001 07:58 pm, you wrote:
> Craig Colton wrote:
> > On Monday 22 October 2001 01:16 pm, you wrote:
> >> I compiled Xfree 4.1.0 and after some trouble (Thanks to Cris..) i made
> >> progresses.
> >>
> >> Still remain a (not little) problem: if i execute xdm it's all ok but if
> >> i run startx then i get this error: "xauth:command not found"
>
>        ^^^^^^
>
> see below ---
>
> > There are some much more capable than I of tackling this, but noone's
> > stepping up to the plate - so I'll try.
> > Seems like I had this problem or one like it and I tweaked
> > /etc/X11/xdm/xdm-config. See if yours looks like mine. I think I changed
> > the "DisplayManager._  authorize: from true to false. This solved my
> > problem, but it may have opened a security hole. I wasn't too worried
> > using dial-up on my home computers, but one should probably find a proper
> > solution to this (don't know where). See if this doesn't help, at least
> > you'd know where the problem is.
>
> From the reference above... This has nothing to do with xdm. xdm does
> not give error, but startx does. To diagnose, from a VT /dev/tty[1-6]
> do a `echo $PATH' and see if it contains /usr/X11R6/bin .
>
> If your PATH does not contain the path to startx and friends then you
> will get this error. Add /usr/X11R6/bin to your PATH; refer to the
> actual /usr/X11R6/bin/startx script for more info about how startx is
> doing its thing...
>
> HTH

I was under the impression (possibly incorrect) that xdm authorizes all 
requests for a display. How might xdm be in one's path and not startx?
   Regards,
   Craig

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list