emu10k1

J.A. Neitzel jan.listbox at belvento.org
Sat Oct 20 08:57:39 PDT 2001


texstefano at libero.it wrote:

>> On Friday 19 October 2001 01:41, you wrote:
>> > I unpacked and compiled emu10k1 under
>> > /lib/modules/2.4.107kermel/driver/net, than copied emu10k1.o
> directly
>> > outside emu10k1 dir. The file modules.dep is:
>> 
>> If you got the drivers from creative, delete them! The source is
> taken up in
>> the kernel. It even has midi support...
>> Don't bother to make them on your own you won't improve anything.
>> 
>> Happy rocking!
>> 
>> Remy
> 
> So, what's the right way have sound?

Right, you don't really need the drivers from creative. This is one
of the OSS drivers that is already in the kernel sources. Sometimes
the one from creative is a little more updated than the one in the
kernel... But, eventually the updates get into the kernel driver also.
This is how I understand it, but ICBW.

So, assuming you have one of the SoundBlaster cards (Live?) with the
emu10k1 chip... If this assumption is correct, you just need to
compile your kernel with sound support.

Choose:
CONFIG_SOUND=y
CONFIG_SOUND_EMU10K1=y

I choose yes (y) and compile everything into the kernel image because
I prefer to not use modules here. If you prefer modules, choose "m"
instead of "y". Then do all the typical kernel compile magic =)

Beware of using this one as a module. Even if you put all the correct
stuff in your /etc/modules.conf, it doesn't exactly behave like you
might expect it to do. It does not seem to autoload, at least not for
me. So, then you would need to apparently `modprobe emu10k1' manually
before you can get your softwares to produce sound.

That is what I remember anyway...
So, you can save yourself un mal di testa by choosing "y" for this
kernel feature.
-- 
Jeff

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list